[hsflinux] driver crashes on amd64

Gour ggdasa at gmail.com
Mon Jul 31 15:00:46 EDT 2006


my 1st post to the list...

I've HP nx6125 with ATI's (1002:4378) controller. Being away from home
(roaming) and regular adsl connection, I've had a need to setup/configure
laptop's modem.

First I tried with slmodem and atiixp driver, but although modem was
dialling, it failed with known NO ANSWER
problem, so I installed hsfmodem driver.

Since it worked, I wanted to support its development and bought 'full'

However, the driver crashed (too often) and produces something like:

Jul 30 09:03:07 [pppd] Using interface ppp0
Jul 30 09:03:07 [pppd] Connect: ppp0 <--> /dev/ttySHSF0
Jul 30 09:03:12 [pppd] PAP authentication succeeded
Jul 30 09:03:12 [pppd] local  IP address
Jul 30 09:03:12 [pppd] remote IP address
Jul 30 09:03:12 [pppd] primary   DNS address
Jul 30 09:03:12 [pppd] secondary DNS address
Jul 30 09:06:21 [kernel] CPU 0
Jul 30 09:06:22 [kernel] Modules linked in: vmnet vmmon iptable_raw
iptable_mangle ipt_ULOG ipt_TTL ipt_ttl ipt_TOS ipt_tos ipt_TCPMSS
ipt_tcpmss ipt_state ipt_sctp ipt_SAME ipt_REJECT ipt_REDIRECT ipt_recent
ipt_realm ipt_pkttype ipt_owner ipt_NOTRACK ipt_NETMAP ipt_multiport
ipt_MASQUERADE ipt_MARK ipt_mark ipt_mac ipt_LOG ipt_limit ipt_length
ipt_iprange ipt_helper ipt_hashlimit ipt_esp ipt_ECN ipt_ecn ipt_DSCP
ipt_dscp ipt_conntrack ipt_comment ipt_CLASSIFY ipt_ah ipt_addrtype
iptable_nat ip_nat ip_conntrack iptable_filter ip_tables hsfusbcd2
hsfmc97sis hsfmc97ati hsfmc97ali hsfmc97via hsfmc97ich hsfpcibasic2
hsfserial hsfengine hsfosspec hsfsoar snd_pcm_oss snd_mixer_oss
snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device
yenta_socket rsrc_nonstatic pcmcia_core tg3 8250_pci 8250 serial_core
snd_atiixp snd_ac97_codec snd_ac97_bus snd_pcm snd_timer
snd_page_alloc fglrx
Jul 30 09:06:22 [kernel] Pid: 7367, comm: khsfd/modem Tainted: P   M
2.6.15-gentoo-r7 #23
Jul 30 09:06:22 [kernel] RIP: 0010:[<ffffffff881930d2>]
Jul 30 09:06:22 [kernel] RSP: 0018:ffff8100439fddb8  EFLAGS: 00010086
Jul 30 09:06:22 [kernel] RAX: 0000000000000000 RBX: f000e3fff000e2c3 RCX:
Jul 30 09:06:22 [kernel] RDX: 0000000000000000 RSI: 0000000000020004 RDI:
Jul 30 09:06:22 [kernel] RBP: 0000000000000032 R08: 0000000000000001 R09:
Jul 30 09:06:22 [kernel] R10: 0000000000000001 R11: 0000000000000000 R12:
Jul 30 09:06:22 [kernel] R13: 0000000000000000 R14: 0000000000000000 R15:
Jul 30 09:06:22 [kernel] FS:  00002aaaaaf03ae0(0000)
GS:ffffffff804e9800(0000) knlGS:00000000556aa6b0
Jul 30 09:06:22 [kernel] CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Jul 30 09:06:22 [kernel] CR2: 00002aaab03a9000 CR3: 000000003bc82000 CR4:
Jul 30 09:06:22 [kernel] Process khsfd/modem (pid: 7367, threadinfo
ffff8100439fc000, task ffff8100460e4240)
Jul 30 09:06:22 [kernel] Stack: 0000000000000001 0000000000000032
ffff810043f2b800 ffff8100439fde68
Jul 30 09:06:22 [kernel]        0000000000000001 ffffffff88197031
ffff810043f2b800 0000000000000032
Jul 30 09:06:22 [kernel]        0000000000000032 ffff8100439fde68
Jul 30 09:06:22 [kernel] Call
Jul 30 09:06:22 [kernel]        <ffffffff882f6370>{:hsfserial:cnxt_intr+624}
Jul 30 09:06:22 [kernel]        <ffffffff8012d470>{default_wake_function+0}
Jul 30 09:06:22 [kernel]        <ffffffff8010f3f6>{child_rip+8}
Jul 30 09:06:22 [kernel]        <ffffffff8010f3ee>{child_rip+0}
Jul 30 09:06:22 [kernel] Code: 48 8b 6f 08 48 89 ef e8 12 f9 ff ff ba 01 00
00 00 85 c0 75
Jul 30 09:06:22 [kernel] RIP
<ffffffff881930d2>{:hsfengine:hsfengine1716_+50} RSP <ffff8100439fddb8>

...or sometimes completely freezes my machine - here is some system info:
nitai gour # uname -a
Linux nitai 2.6.15-gentoo-r7 #23 Fri Jul 28 10:02:46 CEST 2006 x86_64 AMD
Turion(tm) 64 Mobile ML-34 GNU/Linux

nitai gour # gcc -v
Reading specs from /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.5/specs
Configured with: /var/tmp/portage/gcc-3.4.5/work/gcc-3.4.5/configure
--prefix=/usr --bindir=/usr/x86_64-pc-linux-gnu/gcc-bin/3.4.5
--host=x86_64-pc-linux-gnu --build=x86_64-pc-linux-gnu --disable-altivec
--enable-nls --without-included-gettext --with-system-zlib
--disable-checking --disable-werror --disable-libunwind-exceptions
--enable-multilib --enable-java-awt=gtk --enable-languages=c,c++,java,f77
--enable-shared --enable-threads=posix --enable-__cxa_atexit
Thread model: posix
gcc version 3.4.5 (Gentoo 3.4.5, ssp-3.4.5-1.0, pie-8.7.9)

The version of the driver is hsfmodem- (I'm on Gentoo amd64).

Soon i'll be back on broadband, but, still, I'd like to have more stable
'backup' Internet-solution for my laptop.

Any idea?

I don't know whether it's just a coincidence, but the crashes are happening
(almost always) when I'm working with gmail.com account.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxant.com/pipermail/hsflinux/attachments/20060731/f85d0e65/attachment.htm

More information about the hsflinux mailing list