[hsflinux] HSF Modem Driver Problems with HDA modem

Christopher Roger Dennis chris at dennis-family.org.uk
Thu Sep 28 16:00:08 EDT 2006

I have been trying to get the HSF modem driver to work on a Dell Insprion 1300 
laptop with minimal success.

The scan modem tool identifies the HDA chip as 

"Intel 82801FB/FBM/FR/FW/FRW" Class 0403: 8086:2668

and the hsfmodem driver as the correct module.

The base installation is Ubuntu 6.06 LTS with the kernel 2.15.27-386.  I have 
worked out that to use the HDA driver of hsfmodem with this machine I need to 
update the kernel to at least 2.6.16.  I have a version of 2.6.18 built and 
running, but this has not allowed me to progress any further.

However on installation (Version I cannot get the HDA part of 
the driver to function.  I always get the message

"HDA support not compiled in the driver"

No HSF modem is then detected.  I have tried unloading the snd-hda-intel 
module prior to installing the hsf modem, but that did not help.

Any suggestions would be gratefully received at this point.



More information about the hsflinux mailing list