[hsflinux] NO CARRIER message when dialling with kppp or wvdial

Linuxant support (Jonathan) support at linuxant.com
Fri Nov 3 11:24:24 EST 2006


did you do any software upgrades just before the driver was no longer
correctly working? Did you tried to use the modem using another OS just
to make it's not a hardware problem?

The 'NO CARRIER' problem can be related to IRQ sometimes and we can see
the following message in your 'dmesg':

PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a

Did you tried to boot with the 'pci=routeirq' kernel boot parameter as
suggested by the message to see if there is a difference?


Technical specialist / Linuxant
support at linuxant.com

Rob Carruthers wrote:
> hello there,
> i have been using the hsfmodem driver with my modem very happily for a 
> while now, however recently it has ceased to connect to the internet 
> altogether. with kppp or wvdial, it simply gets stuck dialing and 
> produces the message NO CARRIER after a while. i have tried using the 
> init string AT &F X1, as suggested in another recent post, but this 
> makes no difference.
> i have attached my "hsfdiag.txt".
> thanks in advance,
> rob
> _______________________________________________
> hsflinux mailing list
> hsflinux at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/hsflinux

More information about the hsflinux mailing list