[hsflinux] HSF as a fax answers the phone but doesn't beep

Linuxant support (Jonathan) support at linuxant.com
Thu Apr 19 15:18:07 EDT 2007


documentation in PDF format is available at the bottom of this page:


This file describes all the supported AT commands as well as their 
expected return values by the driver.

The new log file shows that there is an attempt to send or receive a FAX 
but it fails for some reason. You could try with a different FAX 
software to see if there is a difference. You could also try with the 
'AT &F' init. string just to make sure it's not the source of the problem.


Technical specialist / Linuxant
support at linuxant.com

Harvey Coward wrote:
> In message <46266484.5060301 at linuxant.com>, "Linuxant support 
> (Jonathan)" <support at linuxant.com> writes
>> Hi,
>> it seems that the FAX software is able to open the serial device and 
>> send commands but there is no reply. This is typical if the serial 
>> device is a physical one on your machine that is connected to nothing.
>> In other words, the "/dev/modem" symlink is probably wrong. Either fix 
>> the symlink or configure your software to use "/dev/ttySHSF0" instead 
>> of "/dev/modem".
> I examined the symlink, it looked OK, then using efax-gtk (different 
> logging) I tried again (Log is below). It shows the HSF modem being 
> used, but then for the avoidance of doubt I asked it to use ttySHF0 - 
> with the same result.
>> You could also try to use a low-level telecommunication tool like 
>> minicom. With that, it will be easier to identify the exact source of 
>> the problem as you will be able to manually send 'AT' commands to the 
>> modem.
> Do you know of a web link that will show me what commands I am supposed 
> to send and what I am looking for?
> ***********************
> Beginning fax log at 0801 BST 19 Apr 2007
> No serial port device specified in efax-gtkrc configuration file
> Using default of /dev/modem
> Socket running on port 9900
> efax-0.9a: 08:01:45 opened /dev/modem
> efax-0.9a: 08:01:46 using hsfmodem- in class 1
> efax-0.9a: 08:01:46 waiting for activity
> efax-0.9a: 08:02:21 activity detected
> efax-0.9a: 08:02:30 fax call answered
> efax-0.9a: 08:02:43 Error: timed out after waiting
> efax-0.9a: 08:02:48 Warning: timed out after waiting
> efax-0.9a: 08:02:51 Error: timed out after command: +FTH=3
> efax-0.9a: 08:02:56 Warning: timed out after command: H
> efax-0.9a: 08:02:30 sent CSI - answering ID
> efax-0.9a: 08:02:48 received CSI - answering ID
> efax-0.9a: 08:03:03 sync: dropping DTR
> efax-0.9a: 08:03:07 sync: sending escapes
> *** Stopping send/receive session ***

More information about the hsflinux mailing list