[hsflinux] HSF as a fax answers the phone but doesn't beep

Chris Vine chris at cvine.freeserve.co.uk
Thu Apr 19 22:25:36 EDT 2007

On Thu, 2007-04-19 at 14:18 -0400, Linuxant support (Jonathan) wrote:
> Hi,
> documentation in PDF format is available at the bottom of this page:
> http://www.linuxant.com/drivers/hsf/full/downloads.php
> This file describes all the supported AT commands as well as their 
> expected return values by the driver.
> The new log file shows that there is an attempt to send or receive a FAX 
> but it fails for some reason. You could try with a different FAX 
> software to see if there is a difference. You could also try with the 
> 'AT &F' init. string just to make sure it's not the source of the problem.

I have experienced the same failure reported here when receiving faxes.
It seems to be a problem with the driver, and after it has occurred it
is not possible to unload all the hsf modules using rmmod (some of the
referencing goes wrong).  Once it has occurred there is nothing to do
but shutdown and reboot the computer, if you want to use the HSF driver.

It may be something to do with the order in which the modules are
loaded.  I have found that it can be avoided by sending a fax (you can
send it to yourself so that you just get a busy message) and then it
will receive OK - but sometimes only once.  Probably one remedy is to
load the modules by hand in the correct order before sending or
receiving any faxes, although I have not taken the trouble to work out
what the correct order is.


More information about the hsflinux mailing list