[hsflinux] Crash report on amd64, intel hda

Ludovico Cavedon cavedon at sssup.it
Mon Oct 22 13:23:26 EDT 2007

Linuxant support (Jonathan) wrote:
> Assuming that it could be a modulation specific issue, which could be
> the case, please try with each (one at a time) of the following init.
> strings, hopefully one of them will be a viable workaround.

I tried some strings (those with autonegotiation disabled):

> ---
> AT &F W1 +ER=1; +DR=1; +MS=V92,0
> AT &F W1 +ER=1; +DR=1; +MS=V34,0
> AT &F W1 +ER=1; +DR=1; +MS=V34,0
> AT &F W1 +ER=1; +DR=1; +MS=V32,0
> ---

But none solved the problem. So I guess it is not modulation related...

I am also experiencing the problem after connecting to HTTPS websites,
however this can hardly be the real cause.

I believe that the problem is related to the upload part of the driver.
In fact I could download for 5 mins at full bandwidth from an http site,
without any problem.

As soon as I start an upload (using scp) the kernel crashes. Maybe when
surfing on an HTTPS website, send packets are bigger than common HTTP
requests, and this may trigger the bug.

I tried to lower the MTU to 1000, but with no help.

Unfortunately I was not able to test an upload without SSL. I you can
suggest me an FTP server or HTTP form where I can upload in cleartext I
would be happy to try!

Thank you for your support,
Best Regards,
Ludovico Cavedon

More information about the hsflinux mailing list