[hsflinux] Ongoing problems with the hsfmodem driver..

Linuxant support (Jonathan) support at linuxant.com
Fri Feb 22 11:52:37 EST 2008


for problem 1, I might have a solution. Please uninstall the driver with 
the 'hsfconfig --uninstall' command in a root shell and then please 
download and install this package:


and then re-install the HSF driver.

It is important to note that the alsa-driver-linuxant package is 
currently experimental and there is no link for in on our web site. It 
received light testing so far but there is no known important problem 
with it.

Only the current version of the HSF driver ( will be able to 
make use of this new alsa-driver-linuxant package.

This will hopefully cure the sound problem, if it was fixed in 
alsa-driver 1.0.16 (upstream ALSA driver).

For the stability issue, you should check again when the code provided 
by Conexant will be updated in the driver. Currently, we use version 
7.68.00 of their code and we are at the 7th release of the Linux driver 
for it, this is where version comes from.

In the meantime, if the init. strings I posted last time were not 
effective, you should try with a 32-bit (x86) distribution of Linux. The 
x86 code is more mature than the x86_64 (64-bit) one, it will hopefully 
improve in future release of the driver.


Technical specialist / Linuxant
support at linuxant.com

Lewis Hopfe wrote:
> I installed the new driver(hsfmodem- over the weekend. 
> However, I continue to have the same problems that I did with the 
> previous version. My machine is a HP 2315 with a AMD64 processor I'm 
> running Fedora 8 64 with the current kernel( #1 SMP)
> . 
> I have a full-version license for the hsfmodem driver.
> Problem 1: When I re-boot to utilize the new driver after
> installation, 
> I don't have any sound and no amount of tinkering will give me any.
> The 
> sound was working fine prior to the install. No error message is
> given 
> and sound appears to be going somewhere, but I get nothing through
> the 
> speakers or headset. When I remove the new driver from my system,
> sound 
> returns with no issues or re-configuration necessary.
> Problem 2: . When I visit a secure site, my computer becomes unstable
> and will eventually hang. This message will appear in both the log
> and 
> any open terminal window:
> Feb 18 09:22:20 localhost kernel: general protection fault: 0000 [1]
> Feb 18 09:22:20 localhost kernel: CPU 0
> This problem happened when I tried the last version of the driver. It
> was suggested that I try a number of initialization strings I've
> tried 
> them again, but none help. Likewise, it doesn't appear to be one
> https: 
> site. It occurs when I log into both of my bank sites as well as my 
> brokerage site.
> I'm out of ideas and ready to give up on this driver. I've never been
> able to get any sort of consistent use from my modem. Any fresh ideas
> would be appreciated.
> Thanks,
> Lewis
>       ____________________________________________________________________________________
> Looking for last minute shopping deals?  
> Find them fast with Yahoo! Search.  http://tools.search.yahoo.com/newsearch/category.php?category=shopping
> _______________________________________________
> hsflinux mailing list
> hsflinux at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/hsflinux

More information about the hsflinux mailing list