[hsflinux] Acer Extensa 5220, OpenSuse 10.3

Friedhelm Stappert friedhelm.stappert at web.de
Wed Apr 16 15:23:45 EDT 2008

Hi all,

I have problems getting the hsf driver running on my Acer Extensa 5220 
with OpenSuse 10.3

After installing (I tried both the binary rpm package as well as the 
source code tar package), hsfconfig says:

Conexant HSF softmodem driver, version

If you need license keys, assistance or more information, please go to:

When reporting a problem for the first time, please send
us the file generated by "hsfconfig --dumpdiag".

No pre-built modules for: SuSE-10.3 linux- i686-SMP

Trying to automatically build the driver modules...
(this requires a C compiler and proper kernel sources to be installed)

Where is the linux source build directory that matches your running kernel?

WARNING: Building older built-in HDA driver; some audio/modem issues may 
If this is the case, please try the latest alsa-driver-linuxant package
available from http://www.linuxant.com/alsa-driver

Building modules for kernel, using source directory
/lib/modules/ Please wait...
Warning: Module snd_hda_intel is in use
Sending TERM signal to processes still using the driver:
  3578 fidi     kmix [kdeinit] -autostart

Warning: no device detected by hsf driver - HDA modems may require reboot

Note: kernel module snd-via82xx-modem overridden by hsfmc97via
Note: kernel module snd-intel8x0m overridden by hsfmc97ich hsfmc97sis
Note: kernel module snd-atiixp-modem overridden by hsfmc97ati


Alas, I cannot post the output of hsfconfig --dumpdiag. When I run this 
command, it says 'probing /dev/ttySHSF...' and never returns.

When I reboot, I get a kernel Oops:
<4>hsfengine: module license 'see LICENSE file distributed with driver' 
taints kernel.
<7>ieee1394: Host added: ID:BUS[0-00:1023]  GUID[001d72ffff0ac38f]
<1>BUG: unable to handle kernel paging request at virtual address 1f6e0000
<1> printing eip:
<1>*pde = 00000000
<0>Oops: 0000 [#1]
<0>last sysfs file: 
<4>Modules linked in: hsfhda hsfserial hsfengine(P) hsfosspec pcmcia 
battery ac container snd_hda_intel snd_hda_codec bcm43xx ohci1394 sdhci 
snd_pcm yenta_socket button i2c_i801 mmc_core ieee1394 snd_timer 
firmware_class nsc_ircc rsrc_nonstatic tifm_7xx1 ieee80211softmac 
serio_raw tifm_core pcmcia_core i2c_core tg3 rtc_cmos sr_mod intel_agp 
snd cdrom irda rtc_core usblp rtc_lib crc_ccitt ieee80211 agpgart 
ieee80211_crypt joydev soundcore sg snd_page_alloc usbhid hid ff_memless 
sd_mod ehci_hcd uhci_hcd usbcore edd ext3 mbcache jbd fan ata_piix ahci 
libata scsi_mod thermal processor
<0>CPU:    0
<0>EIP:    0060:[<f936bc0a>]    Tainted: P      N VLI
<0>EFLAGS: 00010202   ( #1)
<0>EIP is at hsfengine5660_+0x2d39/0x2e7f [hsfengine]
<0>eax: 00000000   ebx: 6e6b065f   ecx: 1f6e0000   edx: 1f6e0000
<0>esi: f7499bf4   edi: f7499bf4   ebp: f7499bf4   esp: f7499b8c
<0>ds: 007b   es: 007b   fs: 00d8  gs: 0033  ss: 0068
<0>Process modprobe (pid: 1318, ti=f7498000 task=dff89ab0 task.ti=f7498000)
<0>Stack: 00000000 6e55a180 c0100000 f7210740 c0000000 00000000 0000001c 
<0>       00000000 c00f7be0 1f6e0000 00000000 00000000 00000000 00000000 
<0>       00000000 00000000 00000000 00000000 00000000 deadaffe f72107c0 
<0>Call Trace:
<0> [<f9364060>] hsfengine1550_+0x70/0xb0 [hsfengine]
<0> [<f9363c8d>] hsfengine519_+0x1d/0x40 [hsfengine]
<0> [<f933d45a>] cnxthsf_ComCtrl_Open+0x6a/0x2e0 [hsfengine]
<0> [<f90b744d>] cnxthsf_cnxt_serial_add+0x21d/0x4e0 [hsfserial]
<0> [schedule+1796/1989] __sched_text_start+0x704/0x7c5
<0> [vsnprintf+1081/1141] vsnprintf+0x439/0x475
<0> [<f90b67b0>] cnxt_event_handler+0x0/0x2f0 [hsfserial]
<0> [<f91322dd>] cnxthwhda_probe+0x19d/0x210 [hsfhda]
<0> [<f9132140>] cnxthwhda_probe+0x0/0x210 [hsfhda]
<0> [<f918f60a>] conexant_init+0x7d/0xc3 [snd_hda_codec]
<0> [<f9184683>] snd_hda_build_controls+0x54/0x6a [snd_hda_codec]
<0> [<f8f9365a>] azx_probe+0x785/0x797 [snd_hda_intel]
<0> [<f8f92624>] azx_send_cmd+0x0/0x127 [snd_hda_intel]
<0> [<f8f9274b>] azx_get_response+0x0/0x1bc [snd_hda_intel]
<0> [<f8f92cef>] azx_get_wallclock+0x0/0xc [snd_hda_intel]
<0> [<f8f92cfb>] azx_get_linkpos+0x0/0x10 [snd_hda_intel]
<0> [pci_match_device+19/158] pci_match_device+0x13/0x9e
<0> [pci_device_probe+54/85] pci_device_probe+0x36/0x55
<0> [driver_probe_device+200/331] driver_probe_device+0xc8/0x14b
<0> [__driver_attach+82/135] __driver_attach+0x52/0x87
<0> [bus_for_each_dev+48/81] bus_for_each_dev+0x30/0x51
<0> [driver_attach+22/24] driver_attach+0x16/0x18
<0> [__driver_attach+0/135] __driver_attach+0x0/0x87
<0> [bus_add_driver+109/381] bus_add_driver+0x6d/0x17d
<0> [__pci_register_driver+75/119] __pci_register_driver+0x4b/0x77
<0> [sys_init_module+5932/6146] sys_init_module+0x172c/0x1802
<0> [do_sync_read+0/266] do_sync_read+0x0/0x10a
<0> [do_sync_read+199/266] do_sync_read+0xc7/0x10a
<0> [pci_bus_read_config_byte+0/97] pci_bus_read_config_byte+0x0/0x61
<0> [sysenter_past_esp+107/169] sysenter_past_esp+0x6b/0xa9
<0> [unix_ioctl+117/149] unix_ioctl+0x75/0x95
<0> =======================
<0>Code: c7 c2 0f b5 17 40 89 ea 8b 55 c0 c7 c6 69 82 0a ad c7 c1 fb f1 
67 6d 89 ef 81 f6 bd 9c ad bf c7 c6 d9 1e 2d 07 89 ee 31 d1 89 d1 <8a> 
02 c7 c7 87 42 ee 77 81 e7 2f 09 00 93 c7 c1 73 d8 a3 c6 89
<0>EIP: [<f936bc0a>] hsfengine5660_+0x2d39/0x2e7f [hsfengine] SS:ESP 
<6>Adding 2104472k swap on /dev/sda5.  Priority:-1 extents:1 across:2104472k
<6>device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised: 
dm-devel at redhat.com
<6>loop: module loaded
<4>fuse init (API version 7.8)
<6>AppArmor: AppArmor initialized
<5>audit(1208374164.873:2):  type=1505 info="AppArmor initialized" pid=2135
Kernel logging (ksyslog) stopped.
Kernel log daemon terminating.

Afterwards, neither modem nor sound do work.

I also tried the linuxant alsa package as suggested by hsfconfig, but 
without success. After installing, neither sound nor modem work.

Any ideas?


More information about the hsflinux mailing list