[hsflinux] Acer Extensa 5220, OpenSuse 10.3

_vi at list.ru _vi at list.ru
Thu Jul 24 08:53:04 EDT 2008

I have the similar problem on Aces Extensa 5220, Debian lenny/sid.
Some time ago hsfmodem worked successfully, but now it crashes in the
same way.
I tried different kernels (2.6.26-wl, 2.6.26, 2.6.24, 2.6.17), different
versions of hsfmodem (-12, -11, -04, -01), different versions of gcc
(4.2.4, 3.4.6), with or without additional ALSA drivers. Every time the
same (but I remember hsfmodem worked before).
Have you found a solution?

usbcore: registered new interface driver hsfusbcd2
ACPI: PCI Interrupt 0000:00:1b.0[A] -> Link [LNKG] -> GSI 11 (level, 
low) -> IRQ 11
PCI: Setting latency timer of device 0000:00:1b.0 to 64
cnxthsf_NVM_Open: cannot create instance 0-HDA-14f12c06:10250093-1: 
err=-2 will retry later...
BUG: unable to handle kernel paging request at 1f6e0000
IP: [<f91b0c0a>] :hsfengine:hsfengine5660_+0x2d39/0x2e7f
*pde = 00000000
Oops: 0000 [#1]
Modules linked in: snd_hda_intel(+) hsfpcibasic3 hsfpcibasic2 hsfmc97via 
hsfmc97sis hsfmc97ich hsfmc97ati hsfmc97ali hsfhda hsfusbcd2 hsfserial 
) hsfsoar hsfosspec ipt_REJECT iptable_filter ipt_MASQUERADE 
ipt_REDIRECT xt_tcpudp iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack 
ip_tables tifm_sd ndi
swrapper binfmt_misc rfcomm l2cap bluetooth ipt_ULOG x_tables sbs fan 
sbshc cpufreq_powersave cpufreq_stats cpufreq_userspace cpufreq_ondemand 
ervative freq_table ipv6 nls_iso8859_1 nls_cp437 dm_snapshot dm_mirror 
dm_log dm_mod sbp2 arc4 ecb usbhid mac80211 joydev cfg80211 
input_polldev nsc_ircc i
rda crc_ccitt sdhci tifm_7xx1 mmc_core ohci1394 tifm_core ieee1394 
yenta_socket rsrc_nonstatic i2c_i801 i2c_core psmouse serio_raw 
snd_pcm_oss snd_mixer_os
s snd_pcm snd_timer snd_page_alloc snd_hwdep snd pcmcia pcmcia_core tg3 
soundcore ehci_hcd uhci_hcd battery ac intel_agp agpgart container 
thermal button p
rocessor acer_wmi led_class evdev wmi [last unloaded: snd_hda_intel]

Pid: 8153, comm: modprobe Tainted: P          (2.6.26-wl #10)
EIP: 0060:[<f91b0c0a>] EFLAGS: 00010202 CPU: 0
EIP is at hsfengine5660_+0x2d39/0x2e7f [hsfengine]
EAX: 00000000 EBX: 6e6b065f ECX: 1f6e0000 EDX: 1f6e0000
ESI: f5265bcc EDI: f5265bcc EBP: f5265bcc ESP: f5265b64
  DS: 007b ES: 007b FS: 0000 GS: 0033 SS: 0068
Process modprobe (pid: 8153, ti=f5264000 task=f526ec30 task.ti=f5264000)
Stack: f76648dc 6e55a180 c0100000 f5265b78 c0000000 00265b80 0000001c 
        00000000 c00f7be0 1f6e0000 00000000 00000000 00000000 00000000 
        00000000 00000000 00000000 00000000 f5265bcc deadaffe f5265bd4 
Call Trace:
  [<f91a9060>] ? hsfengine1550_+0x70/0xb0 [hsfengine]
  [<f91a8c8d>] ? hsfengine519_+0x1d/0x40 [hsfengine]
  [<f918245a>] ? cnxthsf_ComCtrl_Open+0x6a/0x2e0 [hsfengine]
  [<f8b3f4b3>] ? cnxthsf_cnxt_serial_add+0x223/0x520 [hsfserial]
  [<c0132e9f>] ? search_symarrays+0x42/0x7a
  [<c0133077>] ? find_symbol+0x1a0/0x1e2
  [<c0237969>] ? snprintf+0x1b/0x1d
  [<f8b3e870>] ? cnxt_event_handler+0x0/0x2e0 [hsfserial]
  [<f8bd5272>] ? cnxthwhda_probe+0x172/0x1e0 [hsfhda]
  [<f8bd5100>] ? cnxthwhda_probe+0x0/0x1e0 [hsfhda]
  [<f90cb438>] ? conexant_init+0x77/0xba [snd_hda_intel]
  [<f90ce7a8>] ? snd_hda_build_controls+0x41/0x7e [snd_hda_intel]
  [<f90ce721>] ? azx_probe+0x915/0x92e [snd_hda_intel]
  [<f90b98bd>] ? azx_get_response+0x0/0x19b [snd_hda_intel]
  [<f90b9ddb>] ? azx_get_wallclock+0x0/0x10 [snd_hda_intel]
  [<f90b9deb>] ? azx_get_linkpos+0x0/0x14 [snd_hda_intel]
  [<f90b95d5>] ? azx_power_notify+0x0/0x59 [snd_hda_intel]
  [<c0240b8f>] ? pci_device_probe+0x39/0x59
  [<c0294b79>] ? driver_probe_device+0x9f/0x119
  [<c0294c2d>] ? __driver_attach+0x3a/0x59
  [<c029442a>] ? bus_for_each_dev+0x3b/0x5d
  [<c0294a1f>] ? driver_attach+0x14/0x16
  [<c0294bf3>] ? __driver_attach+0x0/0x59
  [<c02947ac>] ? bus_add_driver+0x97/0x1a7
  [<c0294da7>] ? driver_register+0x71/0xcd
  [<c0240d20>] ? __pci_register_driver+0x2e/0x5a
  [<f8a78017>] ? alsa_card_azx_init+0x17/0x19 [snd_hda_intel]
  [<c0134d0a>] ? sys_init_module+0x1593/0x16fc
  [<c0141fc2>] ? unlock_page+0x24/0x27
  [<c014c863>] ? __do_fault+0x2a3/0x2db
  [<c0234fae>] ? prio_tree_insert+0x1c/0x1cb
  [<f8a5b4c2>] ? snd_pcm_format_width+0x0/0x21 [snd_pcm]
  [<c0103863>] ? sysenter_past_esp+0x78/0xb1
Code: c7 c2 0f b5 17 40 89 ea 8b 55 c0 c7 c6 69 82 0a ad c7 c1 fb f1 67 
6d 89 ef 81 f6 bd 9c ad bf c7 c6 d9 1e 2d 07 89 ee 31 d1 89 d1 <8a> 02 
c7 c7 87 42 ee 77 81 e7 2f 09 00 93 c7 c1 73 d8 a3 c6 89
EIP: [<f91b0c0a>] hsfengine5660_+0x2d39/0x2e7f [hsfengine] SS:ESP 
---[ end trace 6412a22e89027d71 ]---

-------------- next part --------------
A non-text attachment was scrubbed...
Name: hsfdiag.txt.7z
Type: application/x-7z-compressed
Size: 31832 bytes
Desc: not available
Url : http://www.linuxant.com/pipermail/hsflinux/attachments/20080724/df97a4b8/attachment-0001.bin 

More information about the hsflinux mailing list