[hsflinux] Sound card disappeared

Linuxant Support (Jonathan) support at linuxant.com
Tue Jul 28 11:55:05 EDT 2009


if you have the following setup:

* You didn't install alsa-driver-linuxant
* You have a HDA sound device
* You don't have a HDA modem, which is the case according to the 
information you have provided

then it is possible that you have hit a known problem. As a workaround, 
use the following commands in a root shell:

hsfconfig --remove
touch /etc/.hsfmodem-hda-disable
hsfconfig -a

If you do not have that exact setup and you don't have 
alsa-driver-linuxant installed, please install it to see if there is a 
difference. It can be downloaded at:


If you require more assistance, please send to support at linuxant.com the 
output of 'dumpdiag'. Type the following in a root shell:

hsfconfig --dumpdiag

Just send us the generated file located in /tmp ('hsfdiag.txt'). It'll 
help us solve the problem.


Technical specialist / Linuxant
support at linuxant.com

Chris Tanner wrote:
> Hello,
> I am running Mandriva Spring 2009.1. When I installed the hsf driver (and 
> rebooted) my sound card disappeared. Pulse Audio can see the USB headset, but 
> not the sound card. Where has it gone?
> hsfconfig --info yields the following:
> Conexant HSF softmodem driver, version
> Note: HDA support not compiled in the driver
> Current parameters: ("hsfconfig --info")
> Config for modem unit 0: /dev/ttySHSF0
> 	Device instance: 0-PCI-14f1:2f30-14f1:2000
> 	HW revision    : Basic2 2.18 Standard DAA 3VoltsIA
> 	HW profile name: hsfpcibasic2hsfi
> 	Registration ID: 19A2-7044-AEC7
> 	License owner  : christopher.tanner at sympatico.ca
> 	License key    : xx-xx-xx-xx-xx
> 	License status : OK
> 	Current region : CANADA (T.35 code: 0020)
> The /dev/modem alias (symlink) points to ttySHSF0
> Regards,
> Chris
> _______________________________________________
> hsflinux mailing list
> hsflinux at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/hsflinux

More information about the hsflinux mailing list