[hsflinux] HDA modem ComCtrlOpen failed (2049), hsfconfig doesn't see modem

Justin J. Snelgrove jj at stormlord.ca
Sun Jul 4 19:56:05 EDT 2010

On 2010-07-04 13:40, Linuxant Support (Jonathan) wrote:

> Just to make sure it's not your custom setup that have a negative impact 
> on the HSF driver, you could try with a stock installation of a common 
> Linux distribution, such as Ubuntu 10.04, to see if the driver works in 
> that setup. With that information, it will help narrow down the source 
> of the problem.

I actually thought of that some time ago. I tried to get both Ubuntu
(10.04) and Fedora (13) working and, while both installed and ran fine,
I ran into problems installing the patched ALSA drivers under both.
Under Fedora, they simply wouldn't compile (due to a known ALSA bug[1]).
With Ubuntu, they would compile and install fine, but I'd receive a
kernel oops (that didn't occur with vanilla Ubuntu) upon reboot -- a
null pointer dereference in the snd-hda-intel module. It was a while
ago, now, and I didn't copy the exact message.

> There are no debug options for the HSF driver to get more debugging 
> messages. The message "ComCtrlOpen failed (2049)" is likely setup 
> problem at the hardware abstraction level, which is the HDA bus 
> driver/codec in your setup and this part is open source code in the 
> alsa-driver package.

Too bad, some more detailed information probably would have helped.

Anyway, I'm actually using Windows 7 with the modem on this laptop now,
as I need to use it to start debugging/testing an ancient data transfer
system. I won't be likely to put much of an effort into fixing it under
Linux, at least not for the foreseeable future. If I have enough spare
time and motivation, I'll keep looking into this sometime later -- if I
do manage to fix it, I'll be sure to report back.

Anyway, thanks for your help.

Justin J. Snelgrove
jj at stormlord.ca

More information about the hsflinux mailing list