[driverloader] DHCP fails for wlan0

don leslie donald.leslie at comcast.net
Sun Jan 4 12:53:59 EST 2004

I am running SuSE 9.0 on an emachine E5312 laptop .

I have installed the drivers and everything seems to look good except 
that DHCP times out ( ... no IP address yet... backgrounding.+ RET=0 ) .

Setting -x in the scripts shows the following ;

wlan0     + ifup wlan0 -o onboot rc

warning: using NO encryption
<notice>checkproc: /sbin/dhcpcd 844
(DHCP) <notice>startproc: execve (/sbin/dhcpcd) [ /sbin/dhcpcd -H -D -N 
-t 999999 -B -h linux wlan0 ], [ CONSOLE=/dev/console TERM=linux 
SHELL=/bin/sh OLDPWD=/etc/sysconfig/network progress=18 
INIT_VERSION=sysvinit-2.82 RUN_FROM_RC=yes REDIRECT=/dev/tty1 
vga=0x317 RUNLEVEL=5 PWD=/etc/sysconfig/network PREVLEVEL=N LINES=38 
HOME=/ SHLVL=4 splash=silent sscripts=42 _=/sbin/startproc 
DAEMON=/sbin/dhcpcd ]

dldrconfig --info

Linuxant DriverLoader for Wireless LAN devices, version 1.53

Web configurator: listening on

Current parameters: ("dldrconfig --info")

Wireless interface name: wlan0 (format "wlan%d")
         MAC address    : 00:90:96:70:CD:FB
         Device instance: PCI-0000:00:0c.0-14e4:4320-144f:7050
         Device driver  : bcm43xx
         License owner  : donald.leslie at comcast.net
         License key    : 37-22-E4-EF-B1-34
         License status : OK (Expires 2004-01-26)

hwinfo --network_ctrl17: PCI 0c.0: 0280 Network controller
   [Created at pci.65]
   Unique ID: lgGW.VSsPRpxTfI6
   Hardware Class: network
   Model: "Askey BCM94306 802.11g"
   Vendor: pci 0x14e4 "Broadcom"
   Device: pci 0x4320 "BCM94306 802.11g"
   SubVendor: pci 0x144f "Askey Computer Corp."
   SubDevice: pci 0x7050
   Revision: 0x03
   Memory Range: 0xd0004000-??? (rw,non-prefetchable)
   IRQ: 10 (3 events)
   Driver Info #0:
     Driver Status: driverloader is active
     Driver Activation Cmd: "modprobe driverloader"
   Config Status: cfg=no, avail=yes, need=no, active=unknown


wlan0     Available private ioctl :
           force_reset      (8C30) : set   0       & get   0
           card_reset       (8C31) : set   0       & get   0

iwlist scan

wlan0     Failed to read scan data : No data available

The locations I tried were using 802.11b . I have not tried to setup for 
11b only.

any ideas ?

Don Leslie

More information about the driverloader mailing list