[driverloader] Airport Extreme & Red Hat 9

Linuxant support support at linuxant.com
Thu Jan 8 04:03:52 EST 2004


instead of modifying the script and hard coding the setting to "restricted",
try putting the following in your interface configuration file

KEY="ABCDEF1234567890ABCDEF1234 restricted"

The quotes are important and of course you need to enter the right key in
HEX format. You can put a key in ASCII format if you prepend "s:" to it.


Jean-Simon Durand
Technical specialist / Linuxant
support at linuxant.com

----- Original Message ----- 
From: "Mat Ellis" <mat.ellis at mac.com>
To: <driverloader at lists.linuxant.com>
Sent: Wednesday, January 07, 2004 6:24 PM
Subject: [driverloader] Airport Extreme & Red Hat 9

I successfully got the Microsoft MN-730 card (based on Broadcom 54g
chipset) to work with my Apple Extreme base station under RedHat 9
(2.4.20-28.9), except when I introduced WEP. I tried all kinds of
combinations, and spent a lot of time with iwconfig with no luck.

Then I saw another post (see
about Suse & Airport Extreme which talked about the 'restricted' mode.

The FAQs suggest you add ' open' or ' restricted' after your WEP key.
However, with my version of RedHat 9, this gave an error when you
activated the interface. I tried to add this manually using iwconfig,
and it seemed to remember the change, but somehow this didn't have the
correct impact.

Instead, I had to hack the script
/etc/sysconfig/network-scripts/ipup-wireless to include this manually.
Look for the line which reads:

iwconfig $DEVICE key $KEY

and amend to

iwconfig $DEVICE key $KEY restricted

This worked for me. Phew, that's half a day lost.

Perhaps the Linuxant folks can do something to deal with this, or at
least add it to the FAQs?

Thanks to Sebastien Stormacq for knocking me out of my bang head
against wall infinite loop.



More information about the driverloader mailing list