[driverloader] Problem compiling Driverloader

David david at starjump.org
Wed Jan 28 13:49:26 EST 2004


I'm attempting to compile from the tarball - my system is Linux from
Scratch-based installation, kernel 2.4.24, gcc v.3.3.1.

make install runs fine, but when I run dldrconfig it falls over. The
dldrconfig-buildlog.txt reads as follows:-

.../modules/kernelcompiler.sh: gcc version 3.3.1 or similar is required to
compile modules for your kernel
rm -f *.o GPL/*.o *.ko GPL/*.ko *.mod.c GPL/*.mod.c .*.cmd GPL/.*.cmd

FALSE -DEXPORT_SYMTAB -o dldrpci.o dldrpci.c
make: *** [dldrpci.o] Error 1

The RPM source-based installation run flawlessly on the Fedora Core 1
installation on the same computer (a Compaq NX7000 notebook), against a
custom kernel compiled from vanilla sources.

Anyone have any clues?

Thanks in advance,


David Elliott

More information about the driverloader mailing list