[driverloader] amd64: dldrconfig fails with "This is for 32-bit targets only"

Tim Gilbert tim at skreak.com
Mon Feb 9 14:52:37 EST 2004


I'm trying to get driverloader working on my eMachines m6805 laptop 
(which has an AMD64 3000+ CPU and a Broadcom wireless chipset).  I'm 
running kernel 2.6.2 basically configured the same as this:


...but that's likely not terribly relevant as I can't get past the 
dldrconfig stage.  When I run it, the make in 
/usr/lib/driverloader/modules fails with the message "This is for 32-bit 
targets only" in GPL/divdi3.c.

As I'm running a 64-bit processor, I'd imagine "64-bit multiplication 
and division" would be fairly trivial, but I haven't quite been able to 
locate where this code should be.  Is there an obvious fix for this? 
I've looked for analagous amd64-specific code in the kernel and glibc, 
but haven't found anything.

Just for kicks, I also tried simply commenting the #error statement in 
this .c files, but then make failed with a linker error:

	ld: Relocatable linking with relocations from el32-i386 
(modules/imported/driverloader-i386.O) to format elf64-x86_64 
(modules/driverloader.o) is not supported

which suggests to me that I stand little chance of getting this working 
unless I can get an amd64 version of the above .O file.

(I've also played around a bit with getting 32-bit emulation to run 
this, as described at
but I haven't yet had much success with driverloader or any other packages.)

Any assistance would be appreciated.


More information about the driverloader mailing list