[driverloader] Need to rerun dldrconfig after boot

Dave Chavez dchavez_yah at yahoo.com
Fri Feb 13 08:47:05 EST 2004


Could it be that the driverloader module is not being loaded?
After running 'ifup eth0' manually, check to see if the module
is loaded (ie, 'lsmod | grep driverloader').  If not, first
load it ('modprobe driverloader') and then try 'ifup eth0'.
If that works, then there's something wrong with auto-loading
of your module.

--- Jack Orenstein <jorenstein at archivas.com> wrote:
> I'm using the Linuxant driver on a Dell D800 laptop running
> RedHat 9 (kernel 2.4.20-28.9), using the builtin wireless nic.
> After I ran dldrconfig, the network connection worked.
> On reboot, eth0 appears to come up, but it does not. If I run ifup
> eth0 manually, it returns instantly with no output and eth0 is not
> working. ifconfig shows loopback only, not eth0.
> However, if I rerun dldrconfig, then ifup eth0 works properly.
> What is dldrconfig doing that is not surviving the reboot, and how
> can
> I fix the problem?
> Here is /etc/sysconfig/network-scripts/ifcfg-eth0:
>      # Please read /usr/share/doc/initscripts-*/sysconfig.txt
>      # for the documentation of these parameters.
>      USERCTL=no
>      PEERDNS=yes
>      GATEWAY=
>      ONBOOT=yes
>      TYPE=Wireless
>      DHCP_HOSTNAME=jack
>      IPADDR=
>      DEVICE=eth0
>      HWADDR=00:90:4b:64:19:2e
>      BOOTPROTO=dhcp
>      DOMAIN=
>      NETMASK=
>      ESSID=RIS
>      CHANNEL=1
>      MODE=Managed
>      KEY=8196508E9ECDD10EA62B065C9D
>      RATE=11Mb/s
> Jack Orenstein
> Archivas, Inc.
> _______________________________________________
> driverloader mailing list
> driverloader at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/driverloader

Do you Yahoo!?
Yahoo! Finance: Get your refund fast by filing online.

More information about the driverloader mailing list