[driverloader] Send-Problems and often Disconnects under heavy load (DLINK-G520+)

Siegbert Laukas siegbert.laukas at laukas.com
Sun Feb 15 19:25:34 EST 2004

after successfully installation and very good read-performance
(>15MB/s), i have the following Problems with my wireless installation:

- used Software: Fedora Core 1 (2.4.22-1.2149.nptl) / CPU Athlon
- user Hardware: DLINK DWL-G520+

- Wireless Settings:

Mode: managed
RTS: off
Frag: off
WEP: 128 Bit/enabled
Power Manag: off
Channel: 06

see iwconfig-output:
eth0      IEEE 802.11-DS  ESSID:"xxxxxxxx"  Nickname:"xxxxxxx"
          Mode:Managed  Frequency:2.437GHz  Access Point: 00:xxxxxxx 
          Bit Rate=54Mb/s   Tx-Power=0 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:xxxx-xxxxx-xxxx ...
          Power Management:off
          Link Quality:1/1  Signal level:-45 dBm  Noise level:-200 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

My problems:
1. By receiving a lot of data (5-10MB) i receive suddenly the message:
kernel: eth0: New link status: Disconnected (0002)

(Previous the data are received very fast (> 15MB/s) and without any

Then, it's needed to restart the driverloader (rmmod/modprobe) and
deactivate/aktivate the network

Then this message is seen:
kernel: eth0: New link status: Connected (0001)

And now i have no problem with receiving any data to the next stop (>
1-10MB) with the same procedure.

The same error is seen under heavy load (receiving a big file ~10MB).
After starting the receive (1-2MB) the receiving is stopped.

2. No Data-Transmitting is possible.

I the actualy situation is not possible to send any Data to an external

Example transmit some files to a SAMBA-Server with mount as smbfs:
kernel: eth0: New link status: Disconnected (0002)
kernel: SMB server not responding
kernel: smb_get_length: recv error = 5
kernel: smb_request: result -5, setting invalid
kernel: smb_writepage_sync: failed write, wsize=4096, result=-5

3. No ping of the wireless-Adapter is available:
When i tried to start a ping, no answer comeback ?

Have someone any help for this failures ?

Best regards
Siegbert Laukas

More information about the driverloader mailing list