[driverloader] So what am I doing wrong?!?

Joe Martine martine3 at cox.net
Sat Jun 12 16:30:32 EDT 2004

I tried those drivers, and got the same result.  I also recompiled the 
kernel with module unloading support.

I then uninstalled the drivers, rebooted to the stock Slackware-9.1 
2.4.22 kernel and tried reinstalling them (1.71).  They installed, but 
would not load.  The driverloader module just gives insmod errors 
(possible incorrect IRQ, so forth...). 

Uninstalled again, and compiled the 1.38 version drivers (again, on the 
2.4.22 kernel) and they installed fine.  Trying the new drivers, still 
no card detected.  I then installed the original Belkin drivers I was 
using, and the card is now working.  Dunno...

I would really like to use the 2.6.x kernels, so I'll experiment some 
more.  Other than that, I'm at a loss unless someone can come up with 
something specific to try!


Linuxant support (Jonathan) wrote:

>please try with a 3.40.x.x version of the Windows XP driver for the Broadcom 
>chipset. You can obtain this driver from the following URL :
>Under Linux, you can use the 'unzip' command on the .EXE file to extract the 
>Windows driver. The required .INF file will be named 'AR/bcmwl5a.inf' inside 
>the .EXE file.
>After you have uploaded the Windows XP driver to the Web Configurator (the 
> web site), you will have to reboot because you have 
>compiled your kernel without the option to unload modules.
>If you are unable to connect to again, please use the 
>'dldrconfig --info' command in a root shell and try again.
>Technical specialist / Linuxant
>support at linuxant.com

More information about the driverloader mailing list