[driverloader] If commands not working using the rc.local workaround

rf frosterrj at sbcglobal.net
Sun Sep 19 17:42:48 EDT 2004

After I boot, card comes up but if I try to ifdown, I get:

[root at localhost robert]# iwconfig
lo        no wireless extensions.

eth0      IEEE 802.11-DS  ESSID:"mynamehere"  Nickname:"localhost"
          Mode:Managed  Frequency:2.437GHz  Access Point:
          Bit Rate=11Mb/s   Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:100/100  Signal level:-62 dBm  Noise level:-154
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.

[root at localhost robert]# ifdown eth0
RTNETLINK answers: No such device or address
RTNETLINK answers: No such device or address

so the card is still up after the ifdown command (all lights going as
usual), and if I just pull the card out, ifup doesnt work to get it

Not sure what commands/package I need to use to manage the card.


OK, just tried to send, and it looks like the ifdown command really took
the card down since send failed and ifup gave me this:

[root at localhost robert]# ifup eth0
Determining IP information for eth0... done.

Previous to using the rc.local work around, ifdown really shut the card
down and the lights went out.  That doesnt seem to be the case now.

On Sun, 2004-09-19 at 06:50, Linuxant support (Jonathan) wrote:
> Hi,
> even if you have used the workaround, you should still be able to bring 
> down your wireless interface with the 'ifdown eth0' command in a root shell.
> What do you mean that the kernel doesn't see the card? Can you see your 
> wireless card in the output of the 'iwconfig' command in a root shell 
> while the DriverLoader module is in the kernel?
> Regards,
> Jonathan
> Technical specialist / Linuxant
> www.linuxant.com
> support at linuxant.com
> rf wrote:
> > I have been using driverloader on MDK 10, newest kernel, but I tried to
> > ifdown the card recently but it seems the kernel doesnt know its there
> > since Jonathan made the suggestion to put this at the end of the
> > rc.local file:
> > 
> > 
> >>Please add the following lines at the end of your '/etc/rc.local' 
> >>file :
> >>---
> >>dldrstop
> >>modprobe driverloader
> >>ifup eth0
> >>---
> > 
> > 
> > to get it up at boot time.  So how do I bring the card down when I
> > want?  I popped it out and then back in again, but ifup doesnt work,
> > again because kernel doesnt see the card.
> > 
> > How do I get control of my card again when it is loaded with the
> > rc.local workaround?
> > 
> > Robert
> > 
> > _______________________________________________
> > driverloader mailing list
> > driverloader at lists.linuxant.com
> > https://www.linuxant.com/mailman/listinfo/driverloader

More information about the driverloader mailing list