[driverloader] wpa_supplicant howto?

Karol Krizka kkrizka at gmail.com
Mon Jan 3 21:15:52 EST 2005

I have just downloaded and installed your driverloader 2.22 on my
Gentoo Linux (on Presrio R3000). It installed without problems and
loaded my driver (Broadcom). But now I can't get it working with
wpa_supplicant (I downloaded the newest stable version from their

This is what I did so far:
zorka root # iwconfig 
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

sit0      no wireless extensions.

eth2      IEEE 802.11g  ESSID:"dunco"  Nickname:"unknown"
          Mode:Managed  Bit Rate=54Mb/s   Tx-Power=25 dBm   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

zorka root # cat /etc/driverloader/dldr_wpa_supplicant.eth2.conf
      psk=<generated with wpa_passphrase>

zorka root # wpa_supplicant -i eth2 -c
/etc/driverloader/dldr_wpa_supplicant.eth2.conf -dd
Configuration file '/etc/driverloader/dldr_wpa_supplicant.eth2.conf'
-> '/etc/driverloader/dldr_wpa_supplicant.eth2.conf'
Reading configuration file '/etc/driverloader/dldr_wpa_supplicant.eth2.conf'
Line: 1 - start of a new network block
SSID - hexdump_ascii(len=5):
     64 75 6e 63 6f                                    dunco           
proto: 0x1
key_mgmt: 0x2
pairwise: 0x8
group: 0x8
PSK - hexdump(len=32): 21 fd b0 32 b1 bb 3a f4 97 40 3c 08 27 fb 0b 68
bb 41 e8 c9 b5 78 51 8a bd 81 84 9d ed 92 73 80
Priority group 0
   id=0 ssid='dunco'
wpa_driver_hostap_set_wpa: enabled=1
wpa_driver_hostap_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_hostap_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_hostap_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_hostap_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_hostap_set_countermeasures: enabled=0
wpa_driver_hostap_set_drop_unencrypted: enabled=1
Setting scan request: 0 sec 100000 usec
Starting AP scan (broadcast SSID)
Wireless event: cmd=0x8b19 len=24
ioctl[SIOCGIWSCAN]: No data available
Scan results: -1
Failed to get scan results - try scanning again

Does anyone know of a HOWTO on the net that explains how to set it up?
Karol Krizka

More information about the driverloader mailing list