[driverloader] PlanetCCRMA-edge kernel and driverloader

jason.ronallo at gmail.com jason.ronallo at gmail.com
Fri Jan 28 22:42:58 EST 2005

I'm using the PlanetCCRMA Fedora Core 3 low latency kernel for audio
work.  All works fine with driverloaderbuild with the
2.6.10-2.1.ll.rhfc3.ccrma kernel. But new patches are being added to
the 2.6.10 kernels to get even better low latency performance for
audio. This latest kernel is 2.6.10-0.4.rdt.rhfc3.ccrma which is based
on 2.6.11-rc2 and Ingo Molnar's 2.6.11-rc2-V0.7.36-05 version of the
realtime preempt patch.
Upgrading to this newest kernel broke driverloaderbuild which stalled
on boot. So I uninstalled driverloader and was able to cleanly boot
into the new kernel.  So I tried again to run the install script. The
install script correctly surmises that I need the generic rpm and it
goes about the business of downloading it and building driverloader.
The build gets all the way to "done."  But then everything freezes. 
On reboot into this new kernel driverloaderbuild looks like it works
fine but then it hangs on driverloader. Booting into the older ll
kernel is fine.

I have not tried the tar package because I cannot get the md5sums to match.

OK, I realize I'm dealing with a very experimental kernel, and don't
expect any easy or quick fixes, but any ideas on what might be the
best way to get driverloader to work?  I don't mind trying whatever. 
Is it possibly a matter of waiting for 2.6.11 to stabilize and
Linuxant to support finally support it?  If that's the case, I suppose
I can be patient and try it again then.  :)  Certainly willing to test
any new developments to driverloader that might help it to work with
my kernel.

Well, here's something more specific: Anyone else trying 2.6.11
kernels with any luck with driverloader?


More information about the driverloader mailing list