[driverloader] HP Pavillion - Broadcom - Large downloads stall

tom tom at nurknet.com
Sat Feb 12 17:07:29 EST 2005

I am experiencing a problem with driverloader.  In particular, longer
downloads (say, over 5MB) will often simply stall.  

I am running on a brand new HP Pavillion zv5470us with P4 HT at 3.2GHz, 1GB
RAM, and a Broadcom BCM4306 chipset.  I have tried various drivers, including
the HP driver that came with the machine, as well as one newer release from
their web site and one older release, just for the heck of it.  I am running
Fedora Core 3 with all current patches (as per apt-get from freshrpms.net).  I
have tried with a stock kernel (2.6.10-1.760_FC3), as well as a self-built
kernel (also 2.6.10).  The latter had the 4KSTACK option DISABLED.

In all configurations, I can reliably create the stall in the following way:

 * Open Firefox and begin a large download (e.g., a file from Sun topping
100MB).  This download will sometimes complete if I do nothing else.
 * While the first large download runs, start another from Firefox.  This
download will stall after a few MB.
 * While the first large download runs, start a SSH scp of a large file.
This download will also stall after a few MB.

Note that the machine does not crash.  I can still surf the web and do other
smaller network operations (e.g., I'm using driverloader to send this email!).
But when I initiate a large download, it will simply stall as above.
Cancelling and restarting (e.g., the SSH scp command) will exhibit the same

Initially, I was trying to do this with ndiswrapper, which exhibits exactly
the same behavior.  I was hoping that Linuxant's commercial solution would
solve the problem, but it is eerily similar.  

I would appreciate any insights folks might have.

Dr. Tom Nurkkala
Lakeville, Minnesota
tom at nurknet.com

More information about the driverloader mailing list