[driverloader] "Invalid module format" error on AMD64 w/ kernel 2.6.10

David Leaman linuxant at pimpninja.org
Tue Mar 15 18:29:49 EST 2005


I've seen one or two problems similar to mine in the archives, but their
fixes don't seem to work on my system (Debian GNU/Linux 2.6.10-9-amd64-k8;
Compaq Presario R3000 series). Here're the symptoms:
driverloader-2.26# make install
[no errors in output]
driverloader-2.26# dldrconfig
[prompts and builds modules]
driverloader: version magic '2.6.10-9-amd64-k8 gcc-3.3' should be
'2.6.10-9-amd64-k8 gcc-3.4'[informational output]
To complete the installation please point your browser to:
driverloader: version magic '2.6.10-9-amd64-k8 gcc-3.3' should be
'2.6.10-9-amd64-k8 gcc-3.4'
driverloader-2.26# modprobe driverloader
driverloader: version magic '2.6.10-9-amd64-k8 gcc-3.3' should be
'2.6.10-9-amd64-k8 gcc-3.4'
FATAL: Error inserting driverloader
(/lib/modules/2.6.10-9-amd64-k8/extra/driverloader.ko): Invalid module
I then try editing the Makefile, which is what I saw mentioned as a
solution in one of the threads. I `make uninstall` then uncomment line 65
in modules/Makefile:CC=gcc
Then I follow the steps above and get exactly the same result. I also try
doing the same thing, but commenting out line 66:
CC := $(shell $(TOP)/modules/kernelcompiler.sh $(KERNELVER)
$(DLDR_KERNELSRC))I repeat the same steps with 'gcc-3.4' and 'gcc-3.3'. Each time I get the
same result: the build seems to work fine, but dldrconfig and modprobe
error out.
I've tried every combination of fixes I can think of. Can someone please
point me in the right direction?

You can find the output of `dldrconfig --dumpdiag` here:

Thank you,



More information about the driverloader mailing list