[driverloader] Problem with suspending to RAM after installing DriverLoader

Linuxant support (Jonathan) support at linuxant.com
Fri Aug 12 11:21:04 EDT 2005


did you tried with different versions of the Windows XP driver to see if 
there is a difference?


Technical specialist / Linuxant
support at linuxant.com

Henrik Nilsson wrote:
> Hi,
> I'm running Fedora Core 4 on a Dell Latitude D600. My kernel is
> 2.6.12-1.1398_FC4 configured as shipped
> (configs/kernel-2.6.12-i686.config), except that the touchpad/stick
> driver has been modified a tiny little bit to make the touchpad/stick
> work when the machine is restarted after a suspend (to RAM).
> I'm having problems with suspend to RAM after having installed
> DriverLoader, used to load a driver for my TrueMobile 1300
> wireless ethernet card. When trying to suspend, five tasks refuse
> to stop:
>     kdldrd/normwork
>     kdldrd/critwork
>     kdldrd/hyperwork
>     kdldrd/dpc
>     kdldrd/wrk
> However, if I first issue the command "dldrconf --rcstop" once, the
> problem goes away completely. I.e. after this, I can enable
> the network and resume and suspend as often as I like without any
> further action. But once I reboot, I again am unable to suspend
> until I've issued the commend "dldrconf --rcstop" once.
> It seems as if issuing the command "dldrstop" is NOT enough to
> make the problem go away, but I have only tried that command once
> so I cannot say with reasonable certainty whether there is any
> real difference between these two commands, or whether the
> behavior is somewhat non-deterministic.
> However, so far, whenever I have rebooted, I'm having the problem,
> and whenever I've issued the command "dldrconf --rcstop" the
> problem appears to go away completely.
> I'm also seeing another side effect of the driver loader installation:
> an attempt is made to start the PCMCIA services twice. However, this 
> problem has already been reported to this mailing list, and editing
> "/usr/sbin/dldrconfig" as suggested to avoid it starting the PCMCIA
> services did indeed solve this issue for me as well.
> Initially, although a long shot, I thought the above two issues just
> might be related, but the first problem unsurprisingly persists
> despite the fix to dldrconfig.
> Best regards,
> /Henrik

More information about the driverloader mailing list