[hcflinux] hcf modem driver crashes my Gentoo 2.6.1 box

Richard Ballantyne rb62 at cornell.edu
Mon Jan 26 15:57:50 EST 2004

First I want to thank linuxant for releasing a 2.6.x compatable HCF modem 
driver.  But I want you to know that it only partially works for me and 
here's why...

The driver installs and works just fine on my Gentoo box _but_ it only works 
if I first run hcfpciconfig prior to using the modem.  Normally you would 
only have to run hcfpciconfig once during the modem driver installation.  
However, I have to run it after _each_and_every_reboot_ because if I dont 
then my machine will crash when I start to use the modem.  The reason why it 
crashes is because all the memory gets used up; the system starts endlessly 
creating sh and modprobe processes which I can see when I do a ps -A.  As I 
said, eventually my box locks up and I have to reboot it.  The lock up also 
occurs if I run modprobe "hfcpciserial" at startup (in my 
/etc/modules.autoload) without first running hfcpciconfig.

This is a very serious failure mode because it could cause me to lose data.  
My filesystems are reiserfs and I prefer to have both read and write caching 
enabled using hdparm.  I don't like to reboot my computer when the 
filesystems haven't been cleanly unmounted.

In the past I used to used the beta version of the hcf modem and everything 
worked.  I only recently needed to use the newer 2.6.x compatable HCF driver 
because I switched to the 2.6.x kernel.  Now I just spent $15 and am 
dissatisfied because it only partially works for me.  This is a very annoying 
bug.  I read through the hcfpciconfig script in an attempt to discover how it 
loads the hcf modules without crashing my box but I couldn't figure it out.  
I shouldn't have to do this anyway because I payed for the driver which isn't 
GPL.  Anyone else experience this bug?

Richard Ballantyne

More information about the hcflinux mailing list