[hcflinux] ubuntu 4.10 (kernel 2.6) asm-68k problem and module loading problem

Michael Salcher michael_salcher at gmx.net
Tue Feb 8 09:31:00 EST 2005


i have an ibook g3 which has a connexant usb modem which should be supported
by your hcf driver. i downloaded hcfusbmodem-1.04powerpcfull.tar.gz and did
"make install". when running hcfusbconfig i run into problems though. i am
running ubuntu 4.10 (warty warhog), a debian based distro. i'm using their
standard kernel i installed the kernel sources but
hcfusbconfig does not complete and the buildlog reads:

include/asm/setup.h:8:28 asm-68k/setup.h: No such file or directory

if i do a "find" i can see that i really don't have such a file.
so what i did was, i edited include/asm/setup.h not to include that line
that says it needs that asm-68k/setup.h file. then hcfusboncifg said it
can't load the driver. i read through info on your website and thought that
i should use the same version of gcc that was used to compile my kernel.
after doing that hcfusbconfig says it can't find my modem. the computer
freezes and everytime at bootup it froze too - but that is fixed again. i
can boot into ubuntu again.
i tried to do hcfusbconfig --dumpdiag but it tries to probe the first device
and then freezes. whenever i try to "modprobe hcfusbhw" the computer
i had a look through the mailing list archives and there are some people who
use debian on a ppc with kernel 2.6 and it does not seem to work for them
either. does that mean the hcf driver just does not work with debian and
that kernel?

michael salcher

DSL Komplett von GMX +++ Supergünstig und stressfrei einsteigen!
AKTION "Kein Einrichtungspreis" nutzen: http://www.gmx.net/de/go/dsl

More information about the hcflinux mailing list