[hcflinux] ubuntu 4.10 (kernel 2.6) asm-68k problem and module loading problem

Linuxant support (Jonathan) support at linuxant.com
Tue Feb 8 11:20:24 EST 2005


we are not aware of this build issue with the kernel 
of Ubuntu and this is strange that the file 'include/asm/setup.h' 
includes a file in a specific architecture directory (68k).

As you have found out, there are known crash issues with the HCF USB 
driver and the 2.6 kernels and we are going to take a look at this 
problem. Please try to generate the dump with the:

hcfusbconfig --dumpdiag --noprobe

command instead of the:

hcfusbconfig --dumpdiag

command, it will probably prevent the crash. You should send us the dump 
at support at linuxant.com, it will help us solve the problem.

In the meantime, you should make sure that your kernel was not compiled 
with the 'CONFIG_PREEMPT' option enabled. Alternatively, you could try 
with a fresh 2.6.10 kernel from http://www.kernel.org to see if there is 
a difference.


Technical specialist / Linuxant
support at linuxant.com

Michael Salcher wrote:
> hi
> i have an ibook g3 which has a connexant usb modem which should be supported
> by your hcf driver. i downloaded hcfusbmodem-1.04powerpcfull.tar.gz and did
> "make install". when running hcfusbconfig i run into problems though. i am
> running ubuntu 4.10 (warty warhog), a debian based distro. i'm using their
> standard kernel i installed the kernel sources but
> hcfusbconfig does not complete and the buildlog reads:
> include/asm/setup.h:8:28 asm-68k/setup.h: No such file or directory
> if i do a "find" i can see that i really don't have such a file.
> so what i did was, i edited include/asm/setup.h not to include that line
> that says it needs that asm-68k/setup.h file. then hcfusboncifg said it
> can't load the driver. i read through info on your website and thought that
> i should use the same version of gcc that was used to compile my kernel.
> after doing that hcfusbconfig says it can't find my modem. the computer
> freezes and everytime at bootup it froze too - but that is fixed again. i
> can boot into ubuntu again.
> i tried to do hcfusbconfig --dumpdiag but it tries to probe the first device
> and then freezes. whenever i try to "modprobe hcfusbhw" the computer
> freezes.
> i had a look through the mailing list archives and there are some people who
> use debian on a ppc with kernel 2.6 and it does not seem to work for them
> either. does that mean the hcf driver just does not work with debian and
> that kernel?
> michael salcher

More information about the hcflinux mailing list