[hsflinux] Device 14F1:2702

Jon Seymour jon.seymour at acm.org
Tue Jan 20 01:56:32 EST 2004

I've got an IBM NetVista (MT 2289) which I believe has a Conexant Soft

I've installed the RPMs and run hsfconfig. Needless to say, the
configuration doesn't recognize the device id. I tried using 
/etc/hsf/inf/linux_intel_smartmc.inf with hsfconfig for no better reason
that this machine seems to have a lot of other Intel devices so perhaps
this device behaves like an intel device. Yeah, a dodgy theory, I know.

Anyway, when I run ifup ppp0, I get:

    hsf_request_port: open failed

There don't seem to be any other messages.

What's my next step? Is this a case where it is likely necessary that I
write a module to match my hardware? I am happy to have a go at doing
that, but I must admit I don't really understand what the first steps in
that direction might be. What do I need to know about the hardware and
how might I find that out? 

But perhaps that is premature...perhaps there is more debugging I can do

Any pointers in the right direction would be appreciated.


More information about the hsflinux mailing list