[hsflinux] Dell Latitude D600: error installing hsfmodem_6.03.00lnxt04082400full_i386.deb

Chao-Cheng Wu chaochengwu at umbc.edu
Sat Nov 13 12:08:29 EST 2004


I'm also using DELL D600 and Debian, but I'm using unstable. When I tried to 
install HSFMODEM, I also got the same error messages. The following message 
which was from linuxant support center solve this problem:

' Since the command 'modprobe /dev/ttySHSF' seems to fail on your
system for an unknown reason, please edit the file '/usr/sbin/hsfconfig'
and change every occurence of 'modprobe /dev/ttySHSF' with 'modprobe
hsfmc97ich' instead.'

Hope this help!

Chao-Cheng Wu
On Saturday 13 November 2004 11:18 am, J M Cerqueira Esteves wrote:
> Greetings
> When trying to install hsfmodem
> (hsfmodem_6.03.00lnxt04082400full_i386.deb) on a Dell Latitude D600
> running Debian Sarge I got:
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Unpacking hsfmodem (from hsfmodem_6.03.00lnxt04082400full_i386.deb) ...
> Setting up hsfmodem (6.03.00lnxt04082400full) ...
> Conexant HSF softmodem driver, version 6.03.00lnxt04082400full
> If you need license keys, assistance or more information, please go to:
>          http://www.linuxant.com/
> When reporting a problem for the first time, please send
> us the file generated by "hsfconfig --dumpdiag".
> No pre-built modules for: Debian-3.1 linux-2.6.7 i686
> Trying to automatically build the driver modules...
> (this requires a C compiler and proper kernel sources to be installed)
> Where is the linux source build directory that matches your running kernel?
> [/lib/modules/2.6.7/build]
> Building modules for kernel 2.6.7, using source directory
> /lib/modules/2.6.7/build. Please wait...
> done.
> ERROR: no device detected by hsf driver
> dpkg: error processing hsfmodem (--install):
>   subprocess post-installation script returned error exit status 1
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Attached you may find the output of hsfconfig --dumpdiag.
> Could this be related to lack of info, in your package, on the device id
> info of the modem on this machine?  (see the lspci output).
> I also downloaded the corresponding ".tar.gz" but was not yet able to
> find the error cause.   Since it seems others have been able to use your
> drivers on Latitude D600 machines, I hope this may simply be caused by
> some failure in device identification...
> Best regards
>                               J Esteves
> PS: the atacched output of dmesg does not start at boot because of the
> length of cryptographic API tests...  I suggest that `hsfconfig
> --dumpdiag' runs dmesg as `dmesg -s 65536', for instance, to have better
> chances of getting some potentially interesting output.  Let me know if
> you need that additional dmesg output from my machine.

More information about the hsflinux mailing list