[hsflinux] Modem works, but doesn't connect ( NO CARRIER)

Linuxant support (Jonathan) support at linuxant.com
Mon Oct 17 14:28:41 EDT 2005


it sounds like an handshaking problem. Please try with each of the 
following init. string, hopefully one of them will solve the problem.

AT &F W1 +ER=1; +DR=1; +MS=V90,0
AT &F W1 +ER=1; +DR=1; +MS=V90,1
AT &F W1 +ER=1; +DR=1; +MS=V34,0
AT &F W1 +ER=1; +DR=1; +MS=V34,1
AT &F W1 +ER=1; +DR=1; +MS=V32B,0
AT &F W1 +ER=1; +DR=1; +MS=V32B,1
AT &F W1 +ER=1; +DR=1; +MS=V32,0
AT &F W1 +ER=1; +DR=1; +MS=V32,1

Please note that these init. strings will only work if you have a valid 
license installed and some of them might not work even if you have a 
valid license installed.

Finally, for the problem setting the country, you are using an 
unsupported way to install the driver (using a package from the Mandriva 
Club repository) and it is quite possible that if you use an official 
package of the HSF modem driver available at:


you will not have this problem.


Technical specialist / Linuxant
support at linuxant.com

Ignacio Fernández Galván wrote:
> Hi,
> I have an IBM Thinkpad R51 with Mandriva LE2005. I installed the
> hsfmodem rpm package from the club repository, the system seems to be
> using the hsfmc97ich driver.
> As far as I know, the modem is working fine, if I set kppp to dial my
> cell phone, it does so an my phone rings. But when I set it to dial my
> ISP number, I only hear a constant "screech" (after the dialing tones,
> of course) and, after a time out, I get a "NO CARRIER" response. The
> same settings (phone number, username...) work fine in windows.
> I tried setting the region with "hsconfig --country", but it gave me an
> empty region list. After creating /etc/.../hsfmc97ich/Region (which was
> missing) as a symlink to /etc/.../hsfpci.../Region (sorry, I don't
> remember the exact name, but it was the name of a module shown by
> lsmod) I could set the region, but I don't know if it's really supposed
> to work in this way. It didn't help, anyway.
> So, now everything seems to be working, except the last step: the modem
> is not replying to the ISP. What am I missing?
> Thanks
> ___________________________________________________________ 
> How much free photo storage do you get? Store your holiday 
> snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com
> _______________________________________________
> hsflinux mailing list
> hsflinux at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/hsflinux

More information about the hsflinux mailing list