[hsflinux] Compaq Presario V3000 Ubuntu 7.04 amd64 - Crash and no Sound

Linuxant support (Jonathan) support at linuxant.com
Mon Oct 29 19:02:54 EDT 2007


for the crash issue, it could be a modulation specific issue and using 
another modulation could be a workaround for the problem. If you do not 
have a license installed, please buy one with our Web Store located at:


and install it. With a license installed, another modulation will likely 
be used. If the crashes happen with the license installed, please try 
with each of the following init. strings:

AT &F W1 +ER=1; +DR=1; +MS=V92,0
AT &F W1 +ER=1; +DR=1; +MS=V92,1
AT &F W1 +ER=1; +DR=1; +MS=V90,0
AT &F W1 +ER=1; +DR=1; +MS=V90,1
AT &F W1 +ER=1; +DR=1; +MS=V34,0
AT &F W1 +ER=1; +DR=1; +MS=V34,1
AT &F W1 +ER=1; +DR=1; +MS=V32B,0
AT &F W1 +ER=1; +DR=1; +MS=V32B,1
AT &F W1 +ER=1; +DR=1; +MS=V32,0
AT &F W1 +ER=1; +DR=1; +MS=V32,1

Hopefully one of them will solve the problem.

Finally, the HDA sound problem with the HSF driver is a known issue on 
some systems. The problem is that the HSF driver have to replace the HDA 
related modules for your kernel with its own versions. This is required 
to support the modem and a complete replacement is required because the 
HDA code provided by ALSA is not modular. This replacement can have an 
impact on sound when you have a HDA sound device.

The HDA code in the HSF driver is based on recent code from ALSA 
mercurial repository. Hopefully, the sound problem for your hardware 
will be solved in a future version of the driver when we will merge the 
newer code provided by ALSA. The ALSA source code can be found in the 
/usr/lib/hsfmodem/modules/GPL/hda directory if you have installed a 
generic package of the driver, it can me modified to fit your system.

To recover sound, you can uninstall the HSF driver with the 'sudo 
hsfconfig --uninstall' command in a shell (Ubuntu specific instructions) 
and reboot the machine, the original HDA modules will be loaded.


Technical specialist / Linuxant
support at linuxant.com

Daniel wrote:
>   Hi,
> I purchased the license for a hsf driver as I'm overseas and forced to 
> used dial-up and sick of battling Vista annoyances.
> The hsf modem driver installed fine, and the dialler is working on an 
> off, maybe one in five dial attempts, for others pppd exists unexpectedly.
> Once connected, the system freezes randomly, an ssh log on another 
> machine doesn't show any kernel log messages about the freeze. The
> freeze seems to be associated with heavy web traffic.
> The laptop has Turion AMD64x2 processors and the modem is Connexant with 
> a HDA Nvidia MCP51 sound system.
> The snd-hda-intel module never worked reliably in Ubuntu 7.04 before the 
> modem driver was installed, now it appears to be working but there is no
> sound at all. As I'm writing on windows, I don't have access to detailed 
> info, but wondered if this is common, I noticed a previous thread on 
> amd64 crashes.
> I'm using the latest drivers, installed from the tar.gz file 
> for x86_64.
> Kind Regards,
> Daniel Clark
> -- 
>   Daniel
>   zhennian at fastmail.fm
> -- 
> http://www.fastmail.fm - Same, same, but different…
> ------------------------------------------------------------------------
> _______________________________________________
> hsflinux mailing list
> hsflinux at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/hsflinux

More information about the hsflinux mailing list