[hsflinux] Problem using cnxtinstall.run with Debian Linux For Conexant HSF 56K Data/Fax Modem

Chris Vine chris at cvine.freeserve.co.uk
Fri Aug 12 11:53:25 EDT 2011

On Fri, 12 Aug 2011 10:30:56 -0400
"P. C. Chan" <p_c_chan at hotmail.com> wrote:
> The laptop I am using now at work requires the alsa driver to be
> patched as well.  I'll try the patch at home to see if it works for
> 3.0.1.  I don't have to patch alsa on my desktop at home.

I thought it was HCF which requires the alsa driver?  The patch will
almost certainly not work with the HCF driver (although you could use it
as a template).
> I think the kernel has changed quite a bit, more than the lock.

Indeed it has.  The patch deals with the relevant changes.  However, a
considerable number of them are to do with changes to the locking
primitives in the kernel (not just the removal of the global lock).
There was also an ioctl change.

> kept patching it on my own till somewhat 2.6.37 and gave up since the
> modem is something I haven't been using for years and probably
> something I can live without.

I use it for faxing.


More information about the hsflinux mailing list