[driverloader] Gentoo, Belkin, NetGear - Unable to modprobe driverloader

Chan Ahn chan at chanahn.com
Sun Jan 11 23:40:48 EST 2004


I am using Gentoo 1.4 and trying to use Belkin 54g (F5D7010). I 
downloaded driverloader 1.54 tar.gz file and compiled without problems. 
I then run dldrconfig, which built successfully the module for kernel 
2.4.22. I then went to and uploaded the correct 
drivers, but no devices were detected. I have pcmcia-cs installed and I 
can see the card working using "cardctl" (although I cannot see the 
power light on on the card...), so I guess pcmcia service is working ok. 
I tried to modprobe and insmod the module, but every time it fails 
saying "driverloader.o init_module: no such device".

I also tried with NetGear 802.11b card (MA521), again with the correct 
Windows driver, but still no devices were detected and I could not load 
the module. So I guess it is not a problem specific to Belkin ones. One 
thing to note is that I tried to use MA521 using another method, by 
downloading RealTek 8180 files, compiling them and loading the resulting 
module, but it still failed, giving the exactly same error (init_module: 
no such device).

Another to note is that I have been using both cards very successfully 
on SuSE using DriverLoader. The RealTek method was also working fine 
with MA521.

I saw somewhere in the mailing that sometimes the ACPI causes problems 
with the driverloader, so I disabled it and tried, yet the same result.....

I have already sent to support at linuxant.com the output from "dldrconfig 
--dumpdiag" a few days ago, but still waiting for their reply.... Can 
someone from Linuxant please help me out??

Or, is there anyone out there, who was under a similar situation as mine 
and fixed the problem??

Thanks a lot,


More information about the driverloader mailing list