[hsflinux] Cannot open modem on Suse 9.1 - no such device or address

gab.cris at virgilio.it gab.cris at virgilio.it
Mon Aug 23 16:48:47 EDT 2004


I've been trying to activate my modem but it doesn't work...
I've got  a Fujitsu-Siemens C1020, with Suse9.1 installed.
The installation procedure detected my modem identifying it by "intel 537
- (AC97 Modem)"
and some of the vendor parameters were correct, though it put "slamr" driver.
I executed scanModem and it seems to me the correct chipset is the Conexant
I tried to use modem but it give me "no answer" after dialing.
I so download hsf driver for Suse (x86) - the 14400 bps free  version -

and installed it (rpm -i xxxx)
i checked the lsmod output and I found various hsf xxx.
but the modem still gives me "no answer" back. (after not checking 'wait
for dialton':
should i leave this check, i got "no dialtone" instead)
I tried "hsfconfig" but it ends with :"ERROR: no device detected by hsf
I so tried by "modprobe ttySHSF0" and it sounds good;
executing "dmesg" gives me back no errors at the end of files.
I sincerely don't know how to proceed (the winmodem into XP runs ok)

I previously had Mandrake 10.0 installed into my Fujitsu and I spent a week
into trying to configure my modem, use all drivers i found into your site,
(rpm, tar) compile, insert modules,
changing initilization string of the modem.... I also copied the info of
windows driver file into linux_via_smartmc.inf but the modem always gave

So i install Suse9.1 hoping to resolve but I see the same problem....
I executed hsfconfig --dumpdiag and got the  output.

Im now attaching the log file i obteined hoping it will be useful...
please help :)

thank you... in advance.... should you need any other info let me know...
bye for now

-------------- next part --------------
A non-text attachment was scrubbed...
Name: hsfdiag.txt.zip
Type: application/x-zip
Size: 20098 bytes
Desc: not available
Url : http://www.linuxant.com/pipermail/hsflinux/attachments/20040823/04953842/hsfdiag.txt-0001.bin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Modem.zip
Type: application/x-zip
Size: 29017 bytes
Desc: not available
Url : http://www.linuxant.com/pipermail/hsflinux/attachments/20040823/04953842/Modem-0001.bin

More information about the hsflinux mailing list