[hsflinux] Conexant modem in Debian Sarge

Linuxant support (Jonathan) support at linuxant.com
Tue Aug 24 15:33:26 EDT 2004


does running the command 'modprobe /dev/ttySHSF' return an error message 
stating that the '/dev/ttySHSF' module is not found? If this is the case 
then please create the '/etc/modprobe.d/hsf' file with the following 

alias /dev/ttySHSF[0-9]* /dev/ttySHSF
alias /dev/modem /dev/ttySHSF
alias char-major-240-* /dev/ttySHSF
alias /dev/cuaHSF[0-9]* /dev/ttySHSF
alias char-major-241-* /dev/ttySHSF
alias char-major-242-* hsfosspec
alias /dev/hsfdiag hsfosspec
alias /dev/hsfdiag* hsfosspec
alias char-major-243-* hsfosspec
options hsfserial serialmajor=XXX calloutmajor=XXX
options hsfosspec dcpmajor=XXX diagmajor=XXX
install /dev/ttySHSF /sbin/modprobe hsfpcibasic2; /sbin/modprobe 
hsfmc97ich; /sbin/modprobe hsfmc97via; /sbin/modprobe hsfmc97ali; 
/sbin/modprobe hsfusbcd2; /bin/true
install hsfserial /sbin/modprobe hsfpcibasic2; /sbin/modprobe 
hsfmc97ich; /sbin/modprobe hsfmc97via; /sbin/modprobe hsfmc97ali; 
/sbin/modprobe hsfusbcd2; /bin/true

You should replace all the 'XXX' with the appropriate numbers that you 
can find in your '/etc/modules.conf' file.

Then, run the following commands in a root shell :

modprobe /dev/ttySHSF

Support for this new '/etc/modprobe.d' mecanism will be added in the 
next release of the HSF driver.


Technical specialist / Linuxant
support at linuxant.com

Ehsan Akhgari wrote:
> Hi all,
> I'm trying to install my Conexant chipset modem in Debian Sarge, using
> kernel 2.6.6-1-686.  I have had successfully installed it on RedHat 9 with
> kernel 2.4.24 before, but I've migrated to Debian since then.
> To install it, I have downloaded the latest .deb package
> (hsfmodem_6.03.00lnxt04072900full_i386.deb) from the LinuxAnt web site, and
> ran "dpkg -i hsf*.deb".  It prompts me that there's no prebuilt binary
> suitable for my kernel, and it needs to build a custom one.  After the
> compilation, it says: Error, module not loaded, and aborts.  I did a bit of
> manual investigation, and it seems that the installation is copying files
> correctly.  The .ko kernel modules are being copied in
> /lib/modules/2.6.6-1-686/misc, but a "lsmod | grep -i hsf" finds nothing.  I
> tried to load all of the modules using modprobe by the following command
> line:
>  for mod in `ls /lib/modules/2.6.6-1-686/misc | awk -F. '{print $1}'`
>  do
>   modprobe $mod
>  done
> And I get no error message.  Then, "lsmod | grep -i hsf" does show the
> modules loaded into the kernel, and /dev/ttySHSF0 is available and
> /dev/modem is a symlink to it, and everything seems like fine, but when I
> run kppp to dial a number, or to query the modem, all I get is a message
> stating "Unable to open modem."  dmesg shows nothing relevant -- only some
> messages which state that the modules are loaded.
> I tried to install the driver on kernel 2.4.26-1-686, and it works fine.
> What can I do to get the modem to work on my system?  Please help me!
> Thanks,
> Ehsan Akhgari
> _______________________________________________
> hsflinux mailing list
> hsflinux at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/hsflinux

More information about the hsflinux mailing list