Re2: [hsflinux] hsfmodem-7.47 driver blocks suspend to disk on SuSE 10.1

wojciech.szenajch at wojciech.szenajch at
Mon Jul 3 18:10:59 EDT 2006


I played a little with the /etc/sysconfig/powersave/sleep file.

First I modified /etc/init.d/hsf script replacing hardcoded 'exit 3' with
'exit 0'
for 'status' option, to make it executed during suspend process (it will be
to have real 'status' option).
Next I added 'hsf' after all default init scripts to the entry:
SUSPEND2DISK_RESTART_SERVICES="slmodemd irda upsd apcupsd hsf"

This made suspend to disk working, but with two limitations:
1. Suspend fails if call is active (more or less expected by me)
2. After returning back from suspend, modem is not working - log file
   /var/log/suspend2disk.log shows that /etc/init.d/hsf was started.
   Also /dev/modem and /dev/ttySHSF0 exist.

After full system reboot modem works correctly.

entry but result was the same (because lack of time I declared only
'hsfosspec' and 'hsfsoar' after default modules and additional 'natsemi'
for my ethernet).

Any suggestions how to make it working after returning back from suspend?
For quick test I used: stty -a </dev/modem which
returned parameters if modem worked or error message
if not.


                    "Linuxant support                                                                                          
                    (Jonathan)"                     To:     wojciech.szenajch at                                      
                    <support at>          cc:     hsflinux at                                        
                    Sent by:                        Subject:     Re: [hsflinux] hsfmodem-7.47 driver blocks suspend to disk on 
                    hsflinux-bounces at        SuSE   10.1                                                               
                    2006-06-28 21:00                                                                                           


as a workaround, did you tried to use the 'hsfstop' command before you
suspend the laptop to see if there is a difference?

Linuxant is working on improving suspend support for the driver and it
is possible that a future version of the driver will offer better
suspend support for the kernel used and your system.


Technical specialist / Linuxant
support at

wojciech.szenajch at wrote:
> I have successuflly installed
> and configured it with YAST, and kinternet. I was able to connect to
> internet with hsfmodem.
> But after installation Suspend to disk hangs after displaying the
> messages:
> Stopping tasks:===========================...========|
> Shrinking memory... done (89588 pages freed)
> After removing hsfmodem package my laptop successfully does suspend to
> process.
> Detatils:
> Laptop HP nx9010, Mobile Intel Celeron 2.4GHz
> MemTotal: 645932 kB
> OpenSuSE 10.1 with the latest patches installed for day 27.06.2006
> (including
> powersave-0.12.18.-0.2)
> Before installing latest patches SuSE 10.1 quite often hanged during
> suspend to disk,
> but was able to do it from time to time. Now it always hangs.
> Attached "hsfdiag.txt" file:
> (See attached file: hsfdiag.txt)
> Wojciech
> ------------------------------------------------------------------------
> _______________________________________________
> hsflinux mailing list
> hsflinux at
hsflinux mailing list
hsflinux at

More information about the hsflinux mailing list